SQL Server 2016 Sp1 legacy cardinality estimation is not valid scoped configuration

By | 8 September 2017

Selamlar,

Eğer konu başlığında yer aldığı gibi SQL Server 2016 SP1 geçişi sonrasında yada SQL Server 2016 Sp1 kurulumu sonrasında SQL Server Management Studio 17.1 / 17.2 versiyonlarını kullanıyorken herhangi bir veritabanın özelliklerine girmek istediğinizde “legacy cardinality estimation is not valid scoped configuration” şeklinde bir hata mesajı alıyorsanız yapmanız gereken Türkçe olan işletim sisteminizin bölge bilgisini değiştirmeniz.

Konu hakkında Microsoft Connect‘de de yazı mevcut.

I've upgraded my test environment from 2014 to 2016SP1, when i right click on database and seleck Properties, im getting this error : legacy cardinality estimation is not valid scoped configuration.

Its about using Sql Server Turkish Collation with OS language Turkish too. 
When i changed OS religion settings to English, all worked fine with ssms 17.1

Details;
https://social.technet.microsoft.com/Forums/en-US/6d2e22e8-ed68-4ecf-97b2-ec1a86157c26/sql-server-2016-sp1-legacy-cardinality-estimation-is-not-valid-scoped-configuration?forum=sqlsetupandupgrade
Share

Leave a Reply

Your email address will not be published. Required fields are marked *